Problems related to Editing

Please check the following indications, if it is not possible to edit objects in WebOffice 10.9 SP1:
 

1.Is it possible to edit the appropriate layer in ArcMap?

2.Is the respective problem reproducible in another WebOffice 10.9 SP1 project?

3.Is the respective problem reproducible in different WebOffice clients (for example: WebOffice core or WebOffice html)?

4.Does the respective problem affect all edit layers or only some particular edit layers?

5.Does the respective problem affect all edit actions or only some particular edit actions?

6.Does the respective problem affect all edit fields or only some particular edit fields?

7.Are there any joins set on the edit layer? If yes: Were these joins created in ArcMap or in WebOffice author?

8.Are you using a versioned layer?

9.Do you have an empty Feature Class or does the edit layer already contain some features?

10.Does the Feature Extent of the appropriate layer cover the full project extent?

Note: You can review and change the appropriate Feature Extent in ArcCatalog via right mouse click on the respective Feature Class -> Properties -> Feature Extent.

11.Do you use domains for the affected Feature Class and did you enter valid values during the editing process?

Note: You can review and change the value range of the appropriate domain in ArcCatalog via right mouse click on the respective Feature Class -> Properties -> Subtypes -> Domains.

12.Does the respective Feature Class in the background of the edit layer contain a database trigger? If yes: Please check the appropriate behavior of this trigger (when it is used and if it is used for all edit actions or only for some particular edit actions - for example CREATE, UPDATE, DELETE)?

13.Do you use ArcGIS Editor-Tracking for the respective edit topic? If yes: Are the appropriate fields for the ArcGIS Editor-Tracking overlapping with the appropriate fields of the user based editing in the WebOffice application configuration as well as with the database trigger?

14.Is it possible to edit on the server, if the respective edit layer is not linked to a Feature Server Endpoint?

15.Is there an alternative Edit DB-Connection available on the appropriate edit layer?

16.If the respective Feature Server is integrated by using GEONIS WebAdapter: Is it possible to edit, when the appropriate Feature Server is not integrated by using GEONIS WebAdapter?

 

Some other special questions if WebOffice usermanagement is used:

 

1.Is it possible to edit without using WebOffice usermanagement?

2.Are the respective Audit Fields (CREATE_BY, CHANGE_BY, CREATE_DAT, CHANGE_DAT, CLIENT_ID) configured correctly both in the appropriate Feature Class as well as in the application configuration?

Note: Please also consider the instructions in chapter Editing Configuration for UserManagement.

3.Is it possible to edit, when the parameter Use UM editing config is turned off on the appropriate edit layer?

 

If the problem still exists after this first analysis, please send a request to the WebOffice Support Team including the results of the points mentioned above. To ensure an optimal support, you also have to consider the other requirements for requesting support.

 

Note: Regarding the creation of the appropriate logfile, which is mentioned in chapter Request Support, it is important that at least the log category FUNCTIONS.EDITING is turned on while reproducing the error.