Sammelpatch für WebOffice 10.9 R5
Erstellungszeitpunkt: 20260930-1825 (= Build #303)
- Dies ist ein Zusatzpatch, d.h. er setzt eine funktionierende Installation von WebOffice 10.9 R5 voraus und beinhaltet alle Fehlerbehebungen sowie neue Funktionen gegenüber WebOffice 10.9 R5!
- Bitte informieren Sie Ihre Anwender, dass nach einer Aktualisierung tlw. der Browser Cache vor dem ersten Aufruf anhand folgender Anleitung gelöscht werden muss.
Voraussetzungen:
Installation von VertiGIS WebOffice 10.9 R5 (mind. Erstellungszeitpunkt: 20251210-1537)
Installation von VertiGIS WebOffice author standalone 10.9 R5 - mind. Build 109.5.0.146
Optional: Installation von VertiGIS Studio Printing Engine (CIM2) - Build 5.32.0.11 (ArcGIS 10.8.1 - ArcGIS 10.9.1)
- Wichtig: Für WebOffice wird im Normalfall der Build “v2” benötigt, welcher auf dem Cartographic Information Model (CIM) v.2 basiert und mit ArcGIS Pro 2.x und ArcGIS Enterprise 10.8.x und 10.9.x eingesetzt werden kann. Die Version “v3” basiert auf CIM v.3 und ist nur mit ArcGIS Pro 3.x und ArcGIS Enterprise 11.x kompatibel. Hintergründe findet man im folgenden HelpCenter Artikel.
Installation Sammelpatch:
- Sichern Sie Ihre WebOffice Web-Applikation (= ganzen WebOffice
Ordner (z.B.:
C:\Tomcat\webapps\<WebOffice Web-Applikation>) kopieren und an einen sicheren Ort ablegen) - Stoppen von Apache Tomcat (über Start/Programme/Verwaltung/Dienste)
- Löschen des Apache Tomcat-Arbeitsverzeichnisses der
WebOffice-Applikation, z.B.:
C:\Tomcat\work\Catalina\localhost\<WebOffice Web-Applikation> - Aktualisierung “ArcGIS Server Object Extension for WebOffice” auf mindestens Stand: 109.5.0.202609282219
- Im ArcGIS Server Manager unter “Services verwalten” das Karten-Service “SynOutputService” stoppen (bzw. alle Kartendienste, worauf die “WebOffice Server Object Extension” aktiviert ist)
- Im ArcGIS Server Manager unter “Site/Erweiterungen” die “WebOffice
Server Object Extension” bearbeiten und
“
<Patch>\ArcGIS for Server Object Extension\syn_soe_ao_gateway.soe” hochladen- Nicht die “WebOffice Server Object Extension” deinstallieren und neuinstallieren, weil sonst die Eigenschaften der “WebOffice Server Object Extension” erneut konfiguriert werden müssen!
- Kopieren Sie den Inhalt von
<Patch>\WebOfficeSystemnach<Laufwerk>\arcgisserver\directories\WebOfficeSystem - Im ArcGIS Server Manager unter “Services verwalten” das Karten-Service “SynOutputService” wieder starten (bzw. alle Kartendienste, worauf die “WebOffice Server Object Extension” aktiviert ist)
- Kopieren der Datei WO109R5_patch_YYYYMMDD.exe in das
WebOffice-Webapplikations-Verzeichnis (z.B.
C:\Tomcat\webapps\<WebOffice Web-Applikation>) - Ausführen der Datei WO109R5_patch_YYYYMMDD.exe und gegebenenfalls alle bestehenden Dateien ersetzen auswählen
- Löschen der Datei WO109R5_patch_YYYYMMDD.exe
- Start von Apache Tomcat (über Start/Programme/Verwaltung/Dienste)
Changelog seit WebOffice 10.9 R5:
2026-09-30
Added
- 406908: SynAdmin: Unterstützung zur Anzeige wie ein ArcGIS Kartendienst publiziert wurde, d.h. entweder ArcMap, ArcGIS Pro 2.x oder ArcGIS Pro 3.x
- 408110: Core: Unterstützung zur Konfiguration (auf Projektebene oder via URL-Parameter “&map_fade”), ob das Ein- und Ausblenden einer Karte animiert werden soll - diese Option ist vorrangig für virtualisierten Umgebungen (z.B. Citrix) ohne dezidierte Grafikkarten gedacht
Fixed
- 398415: Allgemein: Verliert eine Sitzung während der Nutzung ihr zugeordnetes Gruppenprojekt, erscheint nun eine eindeutige Fehlermeldung statt einer irreführenden technischen Meldung
- 398841: Allgemein: Logmeldungen beim Serverstart wurden übersichtlicher gestaltet - weniger Wiederholungen und weniger unnötige technische Details im Logfile
- 399361: Allgemein: Diverse WebOffice Logmeldungen wurden klarer und handlungsleitender gestaltet (u.a. bei abweichenden Servernamen, fehlender Längeneinheit, fehlgeschlagenen Anmeldungen und ArcGIS-Token-Fehlern)
- 406765: Allgemein: Das WebOffice Custom Tool “Popup” (customPopup.htm) konnte in bestimmten Konstellationen mit einer Fehlermeldung abbrechen
- 406766: Allgemein: Die Log-Meldung bei einer doppelt referenzierten Kartendienst-Zuordnung nennt nun den betroffenen Kartendienst sowie die Kartenansicht mit Namen statt nur mit interner ID
- 406907: Allgemein: Fehler bei bestimmten REST-Aufrufen (u.a. GeoOffice Online) werden nun in der WebOffice Logdatei protokolliert, statt unsichtbar zu bleiben
- 407702: Core: Die Selektionsdarstellung soll auch auf großen und hochauflösenden Bildschirmen aus Performancegründen in einem Stück statt in mehreren Teilbildern geladen werden
- 407782: Allgemein: Die Information zu Volltextsuche Subindizes darf bei einem Projektstart nur einmal und nicht zweimal abgefragt werden - in bestimmten Konstellationen kann dies die Projektstartdauer um mehrere Sekunden beschleunigen
- 407828: Allgemein: Optimierung der Logdatei, wenn Services in unterschiedlichen Schreibweisen konfiguriert sind
- 407829: Allgemein: Projekte, deren Initialisierung an einem vorübergehenden Fehler scheitert, sollen wie dokumentiert erneut initialisiert werden und nicht bis zum nächsten Neustart nicht verfügbar bleiben
- 407830: Allgemein: Wenn die WebOffice SOE vorübergehend nicht erreichbar ist, soll das WebOffice Projekt trotzdem starten und nicht wie bisher die gesamte Projektinitialisierung abbrechen
- 407831: WebOffice SOE: Fehler von SOE-Diensten sollen aussagekräftig protokolliert werden: Der bisherige irreführende Hinweis auf zu wenig Speicher entfällt, Überlast und Ausfall sind unterscheidbar, und jeder Initialisierungsdurchlauf schließt mit einer Zusammenfassung ab
- 407875: Allgemein: Die Logmeldung über abweichende ArcGIS Server Versionen eines Hosts benennt nun den betroffenen Host und die Kartendienste und wird bei Esri ArcGIS Online Diensten nicht mehr als Warnung protokolliert
- 407924: Allgemein: Antworten des Servers an den Client werden ohne Content-Type ausgeliefert, wodurch XML-Fehlermeldungen in der Browserkonsole erscheinen
- 407993: Allgemein: Fehler, wenn ein ePaper-Bericht aus einer externen Anwendung bzw. einem Sachdaten-Erfassungsformular (generate_epaper.jsp) angefordert wird
- 407994: Allgemein: Ein Neustart von WebOffice während der Projektinitialisierung soll keine irreführenden Fehlermeldungen erzeugen
- 407996: Allgemein: Verständlichere Protokollmeldung, wenn ein Dienst vom WebOffice-Server aus nicht erreichbar ist: Host, Port und Adresse des Dienstes werden jetzt angegeben
- 407998: Allgemein: Weniger unnötige Anfragen an externe Kartendienste und keine irreführenden Protokollmeldungen bei der Prüfung auf Windows integrierte Anmeldung
- 408079: VertiGIS Printing: Statische Tabellen mit selektierten Features fehlen am Ausdruck
- 408133: Allgemein: Der Abruf der Export-Vorlagen blockiert nicht mehr Login und Projektstart aller Benutzer eines Dienstes; Fehler werden für 5 Minuten gemerkt statt bei jeder Anfrage erneut abgerufen
- 408134: Allgemein: Optimierung der Logmeldung beim Laden von Kartenkacheln
- 408135: Allgemein: Die Logmeldung bei einem Verbindungs-Timeout benennt jetzt die Anfrage, die Dauer und den langsamsten externen Aufruf
- 408136: Allgemein: Die Logmeldung bei einem unlesbaren WMS-Bild ist jetzt kurz und handlungsleitend
- 408147: Flex: Bei Auswahllisten (z.B. beim
Editieren von Attributen) fehlt die Scrollleiste beim ersten
Öffnen
- 408191: Flex: Abhängige Auswahllisten (nicht filterbar) werden beim Editieren nach Änderung des übergeordneten Feldes wieder korrekt aktualisiert
- 408255: Allgemein: Die Volltextsuche berücksichtigt Berechtigungsfilter mit Mandanten-Platzhalter nicht korrekt
- 408256: Allgemein: Logmeldungen zu WFS-Diensten dürfen keine zusätzlichen Anfragen an den Dienst auslösen
- 408288: WebOffice SOE: Von ArcGIS Pro 3.x publizierte Kartendienste werden von der WebOffice SOE nun korrekt erkannt (bisher wurde nur die Ordnerkonvention von ArcGIS Pro 2.x unterstützt)
- 408325: SynAdmin: Tabellen werden in Chrome und Edge nicht vollständig angezeigt
- 408740: Allgemein: ePaper-Ausgaben als Excel, Word oder HTML schlugen fehl, wenn im Projekt “ePaper Ausgaben archivieren?” aktiviert war
- 408752: Allgemein: Beim Laden eines veralteten Projektstands (= SaveState) erscheint im Log nur noch eine Warnung, die die SaveState-ID und die fehlenden Kartendienste nennt
- 408754: Allgemein: Die Warnung zu nicht übernehmbaren Feldern bei “Kopieren von” erscheint nur noch einmal im Log und nennt den tatsächlichen Grund (Feldtyp, Feldlänge oder Anzahl der Stellen)
- 408755: Allgemein: Kann die Editierbarkeit eines Kartendienstes nicht ermittelt werden, erscheint im Log nur noch eine Meldung mit Ursache und betroffenen Layern statt einer Meldung pro Layer
- 408756: Allgemein: Die Logmeldung zur Koordinatensystem-Prüfung von WMS-Diensten soll besser layoutiert werden
- 408761: Allgemein: Das Werkzeug Extract ließ sich nicht öffnen, nachdem im selben Projekt die Geolocation verwendet worden war. Zudem wurde die Geolocation-Position teilweise im falschen Koordinatensystem angezeigt
- 408763: Allgemein: Beim Mapillary Custom Tool wurden in Gebieten mit vielen Aufnahmen nach einem Klick in die Karte kein Bild angezeigt
- 408765: Allgemein: Logdatei: Ein Kartendienst, der beim Projektstart zu langsam antwortet, wird nicht mehr als Warnung zum VertiGIS Request Guard gemeldet
- 408767: Allgemein: Der Wechsel auf eine Hintergrundkarte schlug fehl, wenn die beim Dienst hinterlegte Metadaten-URL mit einem Leerzeichen begann
- 408769: Allgemein: Nicht auflösbare Layer im TOC werden beim Projektstart nur noch einmal pro Kartendienst im Log gemeldet, inklusive Name und Adresse des betroffenen Kartendienstes
- 408770: Allgemein: Layer, deren Name mit einem Leerzeichen endet, erhalten wieder Zahlenformate, Selektionsfarbe und Längen-/Flächenangaben
- 408797: Allgemein: Druck und ePaper: Die Log-Meldung zu Feldern ohne Kennung in einer Druckvorlage beschreibt das betroffene Feld jetzt genauer und erklärt, wie es korrigiert wird
- 408799: Allgemein: Logmeldung für nicht gefundene Editierfelder verwies fälschlich auf eine andere Logkategorie
- 408804: VertiGIS Printing: Initialisierungsprobleme beim WebOffice SOE Druck dürfen die Verfügbarkeit von Druckvorlagen auf Suchergebnissen nicht beeinflussen
Changed
- 406764: Allgemein: Die Lizenzprüfung liefert nun eine eindeutige Fehlermeldung, wenn die Lizenzdatei für eine andere WebOffice-Version ausgestellt wurde als die aktuell laufende Instanz - statt der bisherigen, generischen Meldung, dass keine gültige Lizenz vorhanden ist
Security
- 408753: Allgemein: API-Schlüssel und Tokens externer Dienste (z.B. Bing Maps) werden in der WebOffice-Logdatei nicht mehr im Klartext ausgegeben
- 408384: Allgemein: Die Software-Stückliste (SBOM) von WebOffice enthält jetzt auch alle mitgelieferten JavaScript-Bibliotheken (u.a. ArcGIS Maps SDK, jQuery, pdf.js, Swagger UI)
- 408405: SynAdmin: WebOffice Administration: Anzeige der registrierten Service-Endpunkte verwendet eine aktuelle, sicherere Version des JSON-Viewers
2026-09-18
Added
- 399416: SynAdmin: Unterstützung zur Anzeige der Logkategorie in der WebOffice Logdatei
Fixed
- 343322: WebOffice SOE: Die Log-Meldung beim Hochladen von Sammel-/Gruppenobjekten soll den betroffenen Kartendienst-Layer ausgeben
- 398896: Allgemein: Regression durch
398878 verursacht, dass WebOffice Projekte mit dem
Werkzeug GeoOffice Online (AGDA) nicht starten
- 399317: Allgemein: Doppelte Log-Meldung bei ungültiger Zeitschieberegler-Konfiguration vermeiden
- 399318: Allgemein: Projektname in Meldungen zum Neuladen von Diensten/Datenbanken ergänzen
- 402262: Allgemein: Regression durch
311286 verursacht, dass abgesicherte Kartendienste
nicht angezeigt werden können
Changed
- 230769: Core: Werkzeug für k5 Personensuche soll an die aktuelle k5-Finanz-Schnittstelle (Version 1.17) angepasst werden
- 398878: Allgemein: Technische Modernisierung der GeoOffice Online (AGDA) Anbindung
Security
- 398176: Allgemein: Aktualisierung der referenzierten Chart.js-Bibliothek in diversen WebOffice Custom Tools
- 398888: Allgemein: Aktualisierung von GeoTools auf v35.1
2026-09-12
Added
- 394752: Allgemein: Unterstützung zur Bereitstellung eines SBOM (Software Bill of Materials) für VertiGIS WebOffice
- 394866: VertiGIS Printing: Unterstützung für VertiGIS Studio Printing Engine v5.32.0.11
- 397896: SynAdmin: Unterstützung zum Exportieren der Projektinitialisierungs-Details als CSV-Datei
- 397900: SynAdmin: Unterstützung für WebOffice Logfile Explorer
Fixed
- 173060: Allgemein: Redlining mit einem einzelnen Koordinatenpunkt (Linie) wurde stillschweigend verworfen statt als Punkt dargestellt
- 173169: Allgemein: Optimierung der Fehlermeldungen, wenn die WebOfficeDataShare Konfiguration nicht valide ist
- 173242: Allgemein: Fehler bei der Initialisierung eines ArcGIS Kartendienstes, wenn die Versionsnummer des ArcGIS Server nicht ausgelesen werden kann
- 223416: Core: Im Firefox wird beim ArcGIS WebScene Custom Tool das Vollbild-Icon nicht dargestellt
- 234099: Allgemein: Excel-Export bricht ab, wenn ein Ergebnisfeld mit Verknüpfung zu einer Externen Anwendung kein gültiges Verknüpfungsziel hatte
- 248293: Allgemein: Fehler beim Abruf einer gespeicherten Abfrage auf ArcGIS Server Kartendiensten, welche die Query-Operation nicht unterstützen
- 250060: Allgemein: MS Access Datenbanken verursachen in der Logdatei vom Apache Tomcat sehr viele Logeinträge
- 302356: Core: Google Maps Custom Tool: Konfigurierter Kartentyp wird nicht berücksichtigt
- 305322: WebOffice SOE: Statusseite des SOE-Gateway funktionierte mit aktuellen Java-Versionen nicht
- 311286: Allgemein: Bestimmte WMS/WMTS-Dienste mit Basic Authentication werden nicht angezeigt
- 333106: Allgemein: Fehler, wenn UserManagement in der Rollen-Rechteliste ein leeres Element liefert
- 336738: Core: Themenstatus (an/aus) werden für AnnotationSublayer in der StateID nicht übernommen
- 361857: VertiGIS Printing: Weitere Optimierung für Seriendruck über ausgewählte Objekte
- 375768: Allgemein: Projekt startet nicht, wenn für “ArcGIS Server Extract-Service” fälschlicherweise eine GPServer-URL statt einer MapServer-URL konfiguriert wird
- 376033: Allgemein: ePaper-Berichte können nicht in allen Szenarien mittels einer Kopplung externer Anwendung generiert werden
- 378620: Allgemein: Entladene Projekte stehen auf Landing Page nicht zur Verfügung
- 380037: Core: Beim Werkzeug “Karte überlagern” wird eine geänderte Überlagerung erst nach Pan/Zoom sichtbar
- 381048: Core: Bestimmte Konstellationen einer Ribbon Konfiguration verursachen eine Fehlermeldung in der Browserkonsole
- 386987: Allgemein: Regression durch 336738 verursacht, dass SaveStates von älteren WebOffice Versionen nicht mehr korrekt geladen werden können
- 387091: Allgemein: WebOffice Projekte starten nicht, wenn die URL zur FTS-Index Applikation nicht korrekt konfiguriert ist
- 390053: VertiGIS Printing: Selektionen in der Grundkarte wurden nicht mitgedruckt
- 390895: Core: Fehler beim Hochladen einer KML-Datei, wenn keine temporäre Gruppenebene gefunden wird
- 392442: Core: Werkzeug “Karte exportieren” liefert keine Selektion mit
- 394750: SynAdmin: SQL Server 2022 sowie 2025 werden nicht mit sprechendem Editionsnamen angezeigt
- 394914: Allgemein: Die MGRS Custom Tools referenzieren nicht auf die korrekte ArcGIS Maps SDK for JavaScript Version der WebOffice Applikation
- 395075: Allgemein: Sporadische Verbindungsfehler bei der Anbindung an die Volltextsuche
- 395114: Map Widget: Fehler bei bestimmten Werkzeugkonfigurationen
- 395126: Allgemein: Relative bzw. protokolllose Dienst-URLs werden teilweise nicht mehr korrekt erkannt
- 396717: Allgemein: Fehlerhafte Sitzungsbehandlung kann in bestimmten Proxy-Szenarien zu Zugriffsfehlern führen
- 396763: Allgemein: Fehlermeldung bei Token-Fehlern um Kontextinformationen erweitert
- 396764: Allgemein: Log-Meldungen bei fehlendem Projekt-Parameter kompakter und aussagekräftiger gestaltet
- 396809: Allgemein: Die Encodierung von zusammengesetzten URLs mit Prefix/Postfix bei Aufruf externer Anwendung ist in bestimmten Fällen nicht korrekt
- 396885: Allgemein: Unklare Fehlermeldung, wenn ein Editierlayer über kein ObjectID-Feld sowie über keine PrimaryField Konfiguration verfügt
- 396957: Allgemein: Beim Werkzeug zum dynamischen Hinzufügen eines ArcGIS Server-Service werden die vorkonfigurierten Kartendiensteigenschaften wie Bildformat und Timeout ignoriert
- 396985: Allgemein: Übermäßige Logfile-Einträge bei OGC-Dienst-Token-Prüfung reduziert
- 396986: Allgemein: Esri World Imagery Wayback WMTS-Dienste verursachen unnötige Warnungen in der Logdatei
- 396993: Allgemein: Bei unerwarteten HTML-Antworten
von Diensten (z.B. durch Proxy/Wartungsseiten) soll ein lesbarer Auszug
statt Roh-HTML in der Fehlermeldung angezeigt werden
- 396995: WebOffice SOE: Beim Abrufen der Legenden-Information verursacht ein leeres Symbolbild einen Fehler statt korrekt leer angezeigt zu werden
- 396996: Allgemein: Fehler beim Start eines Projekts ohne aktive Session in bestimmten Szenarien
- 397118: Allgemein: Zertifikatsfehler in der WebOffice Logdatei sollen sprechender und mit Hinweisen zur Fehlerbehebung versehen werden
- 397125: WebOffice SOE: Mehrdeutige Zuordnung von Konfigurationswerten in seltenen Fällen behoben
- 397155: VertiGIS Printing: Fehlermeldung nach Ablauf der Wartezeit beim Drucken um mehr Details ergänzt
- 397649: WebOffice SOE: Optimierung der Statusabfrage des SOE-Gateway auf Windows-Servern
- 397768: Allgemein: Fehler bei der Prüfung, ob
Editierlayer wirklich zum Editieren zur Verfügung stehen, sollen in der
WebOffice Logdatei sprechender und mit Hinweisen zur Fehlerbehebung
versehen werden
- 397796: Allgemein: Fehler bei der Prüfung des
Passwort-Ändern-Werkzeugs, wenn UserManagement noch nicht initialisiert
ist
- 397812: Allgemein: Wiederholte, identische Warnungen werden bei jedem Request geloggt
- 397814: Allgemein: Eine leere Serverantwort einer WMS Kartenabfrage führte zu einem Fehler statt zu einem leeren Kartenbild
- 397817: Allgemein: Fehlermeldung bei ungültiger externer Anwendungs-URL soll nicht mehr den rohen technischen Klassennamen zeigen
- 397850: Allgemein: Doppelte, kontextlose Log-Einträge sollen vermieden werden
- 397894: Allgemein: Wiederkehrende Log-Meldungen bezüglich nicht vorhandener konfigurierter Felder für die Volltextsuche sollen nicht alle 90 Sekunden geloggt werden
- 397895: VertiGIS Printing: Wiederkehrende Log-Meldung zu einer fehlenden Druckvorlage soll nur einmal, statt je Session geloggt werden
- 397983: WebOffice SOE: Kartendienste mit bestimmten Mosaik-Datensätzen verursachten einen Fehler
- 397984: WebOffice SOE: Aussagekräftigere Fehlermeldung bei fehlgeschlagenen SOE-Transaktionen
- 398011: WebOffice SOE: Log-Meldung bei einem SOE-Gateway-Fehler soll den tatsächlich betroffenen Bereich zeigen
- 398084: Allgemein: Fehler beim Zugriff auf das ArcGIS Server Admin Interface sollen in der WebOffice Logdatei sprechender und mit Hinweisen zur Fehlerbehebung versehen werden
- 398093: Allgemein: Wiederholte, identische Berechtigungsfehler sollen nur einmal pro Session statt bei jedem Aufruf geloggt werden
- 398191: Allgemein: Durch die WebOffice SOE ermittelte Hinweise auf Broken Datasources in einer einem ArcGIS Server Kartendienst zugrunde liegenden MXD sollen an die WebOffice Logdatei durchgereicht werden
- 398347: WebOffice SOE: Kartendiense von aktuellen ArcGIS Server-Versionen verursachen viele Logeinträge auf DEBUG-Level
- 398413: WebOffice SOE: Fehlerhaft formatierte Diagnosemeldung bei ungültigen Daten von ArcGIS Server behoben
- 398582: Core: Diverse Optimierungen für das ArcGIS WebScene: Basemap-Filter, Building Explorer, Koordinatenumrechnung
- 398600: Allgemein: Bei zu vielen fehlgeschlagenen Loginversuchen soll eine passende Meldung an den Endanwender erfolgen
- 398782: Core: Export der clientseitigen Log-Dateien schlägt bei bestimmten Sonderzeichen fehl
- 398785: Allgemein: OGC WFS-Dienste mit sehr vielen Feature Types erzeugen bei fehlendem Feature Type einen unnötig langen Logeintrag
- 398799: Core: Fehler bei “Kundeninformation”, wenn während des Lades die Größe des Browserfensters geändert wird
- 398837: SynAdmin: VetorTile Services verursachen, dass man aus SynAdmin wegen einer abgelaufenen Session geworfen wird, wenn man auf den Reiter “Kartendienste” wechselt
- 398876: Allgemein: Eine fehlerhafte GeoOffice Online (AGDA) Konfiguration führt dazu, dass der gesamten Projektstart verhindern wird
- 398881: Allgemein: Potentielles Speicherleck sowie Warnungen in der Apache Tomcat Logdatei behoben
Changed
- 397602: Allgemein: Aktualisierung des Oracle JDBC-Treibers auf v23.8.0.25.04
- 398878: Allgemein: Technische Modernisierung der
GeoOffice Online (AGDA) Anbindung
Security
- 376785: Allgemein: log4j v1.2.17 mit reload4j v1.2.26 ersetzen
- 394854: Allgemein: Aktualisierung der Excel-Export-Bibliothek (= Apache POI auf v5.5.1)
- 394855: Allgemein: Wechsel der PDF-Bibliothek von iText v2.1.9 auf OpenPDF v2.4.0
- 394897: Allgemein: Aktualisierung von Spring Framework auf v6.2.19
- 394904: Allgemein: Aktualisierung der aircompressor-Bibliothek auf v2.0.3
- 394905: Allgemein: Aktualisierung des SQLite JDBC-Treibers auf v3.53.2.1
- 394906: Allgemein: Aktualisierung des PostgreSQL JDBC-Treibers auf v42.7.13
- 394907: Allgemein: Aktualisierung des Microsoft JDBC-Treibers für SQL Server auf v12.2.1
- 394908: Allgemein: Aktualisierung des OWASP Java HTML Sanitizers auf v20260101.1
- 394909: Allgemein: Aktualisierung von Apache Commons Configuration2 auf v2.12.0
- 394911: Allgemein: Passwort-Parameter konnte in bestimmten Fehlermeldungen ungeschützt angezeigt werden
- 394957: Core: XXE-Schwachstelle bei der Verarbeitung von XML-Daten im Zuge des Hochladens einer GPX-Datei
- 395049: Allgemein: Aktualisierung der SwaggerUI-Bibliothek auf v5.32.14
- 396879: Allgemein: Aktualisierung von Jackson Databind auf v2.18.9
- 396880: Allgemein: Aktualisierung von Apache Commons Configuration2 auf v2.15.1
- 396881: Allgemein: Aktualisierung von Log4j-API auf v2.2.6.1
- 396882: Allgemein: Aktualisierung der Volltextsuche-Komponenten (Solr/Jetty)
- 398173: Core: Stored-XSS-Schwachstelle bei gespeicherten Abfragen behoben
2026-07-01
Fixed
- 371012: SynAdmin: Fehler beim Login nach Eingabe eines Passwortes mit bestimmten Sonderzeichen
- 386776: Allgemein: Versionskonflikt bei GeoTools-Bibliothek verursacht, dass der GeoTIFF Export nicht funktioniert
- 387091: Allgemein: Erweiterung der Log-Informationen bezüglich des ProxySelector
2026-06-23
Fixed
- 386550: Map Widget: Fehler beim Verorten von Objekten im Fadenkreuzmodus, weil im Hintergrund fälschlicherweise die Link-Logik vom Werkzeug “Create or Link” durchlaufen wird
2026-06-11
Added
- 343734: Flex: Unterstützung zum Erstellen von ePaper-Berichten via ScriptAPI
Fixed
- 381088: Allgemein: Regression aus
370605 verursacht Fehler beim Drucken, wenn bei
UserManagement der Parameter “Rechte und Einschränkungen aggregieren?”
auf “false” konfiguriert wird
- 375511: SynAdmin: Regression aus dem Wechsel auf Java 21 verursacht, dass gültige MAC-Adressen auch unter “Für Lizenzierung nicht gültig” gelistet werden
- 376033: Core: ePaper-Bericht kann nicht aus Kopplung externer Anwendung mit generate_epaper.jsp generiert werden
- 380608: Allgemein: Im Modus “Sichtbare Themen” wird der MapTip für WMS-Layer angezeigt, obwohl der WMS-Layer im Themenbaum nicht aktiv ist
- 381976: VertiGIS Printing: Nach einer filternden Suche sind im Ausdruck alle Objekte vorhanden und es findet keine Filterung statt
- 381088: Allgemein: Regression aus
370605 verursacht Fehler beim Drucken, wenn bei
UserManagement der Parameter “Rechte und Einschränkungen aggregieren?”
auf “false” konfiguriert wird
2026-05-20
Fixed
- 379547: Allgemein: Regression durch 370605 verursacht, dass in einigen Szenarien Werkzeuge wie Drucken nicht funktionieren
- 380037: Core: Werkzeug “Karte überlagern” funktioniert mit ArcGIS Maps SDK for JavaScript 4.34 nicht
Changed
- 378055: Allgemein: Aktualisierung auf Swagger Core 3 Version 2.2.49
2026-05-10
Added
- 376820: VertiGIS Printing: Unterstützung für VertiGIS Studio Printing Engine v5.30.2.2
Fixed
- 375971: Allgemein: WMS-Dienste mit vertauschter Achsenreihenfolge werden nicht angezeigt, weil WebOffice den Parameter für die Bounding Box nicht korrekt übergibt
- 378599: Core: WebOffice Projekte starten nicht, wenn WebOffice Themenfilter mit Lookups verwendet werden und kein Standardwert hinterlegt ist
Changed
- 323585: Allgemein: Aktualisierung der in WebOffice hinterlegten EPSG Codes und Achsenausrichtungen auf den Stand 12.055
Security
- 370605: Core: Es muss überprüft werden, ob die Werkzeuge EDIT, UPLOAD, PRINT, EXTRACT und EPAPER für den Benutzer in der Session aktiviert sind und ob der Benutzer für die entsprechenden Werkzeuge berechtigt ist
2026-04-08
Added
- 341204: Flex: Unterstützung zur Konfiguration des Animationsverhaltens sowie der Animationsgeschwindigkeit
Fixed
- 356029: Core: Kartendienste werden in bestimmten Szenarien nicht nachgeladen, wenn Transparenzen auf Kartendienste angewendet werden
- 361857: VertiGIS Printing: Seriendruck über ausgewählte Objekte funktioniert nicht
- 362159: Core: Panoramabilder sollen keine Ablage in Unterverzeichnissen, welche sich vom Dateinamen ableitet, erfordern
- 364181: VertiGIS Printing: Bei einer rotierten Karte ist die Beschriftung nicht korrekt ausgerichtet
- 368688: Core: Fehler beim Upload einer GPX-Datei
- 368790: Flex: Fehler beim Identifizieren führt dazu, dass der WebOffice Flex-Client einfriert
- 368851: Allgemein: Bestimmte WFS-Dienste verursachen eine Fehlermeldung in der WebOffice Logdatei
- 374322: Core: Fehler beim Werkzeug “Karte exportieren” sowie GeoTIFF Export
Security
- 370602: Allgemein: Nach Eingabe eines inkorrekten Passwortes im Zuge eines Login-Vorgangs darf der WebOffice-Applikationsserver das Passwort nicht an den WebOffice-Client senden
2026-02-27
Added
- 341204: Core: Unterstützung zur Konfiguration des Animationsverhaltens sowie der Animationsgeschwindigkeit
- 344723: Core: Unterstützung für “generateState” in
der ScriptAPI zur Erstellung eines SaveStates
- 358317: Core: Unterstützung für Maptip auf Layer
eines WMS-Dienstes, welche die Identify Operation unterstützen
- 365665: VertiGIS Printing: Unterstützung für
VertiGIS Studio Printing Engine v5.29.1.2
Fixed
- 344358: Flex: Extract via Popup (Identify/Suche) auf einem GIS-Objekt funktioniert nicht
- 344667: Core: Regression aus 325600 verursacht Probleme beim Werkzeug Kartenüberlagerung
- 358540: Allgemein: WebOffice Themenfilter auf
Layer, welche mit identischen Coded Value Domains konfiguriert sind,
funktioniert nicht
- 362499: Allgemein: Beim WebOffice SOE Druck mit
dynamischer Legende sind Legendensymbole verschoben, wenn der zugrunde
liegende Font Symbole in unterschiedlichen Größen beinhaltet
Security
- 233833: Allgemein: Aktualisierung auf jQuery 3.7.1 - Wichtig: alle individuell erstellten JSP-Dateien, welche auf die inkludierte jQuery-Bibliothek referenzieren, müssen im Zuge der Aktualisierung gegebenenfalls angepasst werden
- 360547: Allgemein: Apache Commons Text auf Version 1.15.0 aktualisieren
WICHTIG:
- Alle vorgenommenen Fixes wurden hinsichtlich der Fehlereinmeldungen der Kunden getestet.
- Aufgrund der Komplexität des Produkts können neue Abhängigkeiten nicht ausgeschlossen werden.